Published On: July 20ᵗʰ, 2021 07:30

Multiprotocol Label Switching (MPLS) Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Configuring 6VPE

This section provides information about Configuring 6VPE on the switch.

Restrictions for 6VPE

  • Inter-AS and carrier supporting carrier (CSC) is not supported.

  • VRF Route-Leaking is not supported.

  • eBGP as CE-PE is not supported.

  • EIGRP, OSPFv3, RIP, ISIS, Static Routes are supported as CE-PE.

  • MPLS Label Allocation modes supported are Per-VRF and Per-Prefix. Per-Prefix is the default mode.

  • IP fragmentation is not supported in the Per-Prefix mode of Layer 3 VPN.

  • DHCPv6 is not supported on a 6VPE topology with per-port trust enabled.

Information About 6VPE

6VPE is a mechanism to use the IPv4 backbone to provide VPN IPv6 services. It takes advantage of operational IPv4 MPLS backbones, eliminating the need for dual-stacking within the MPLS core. This translates to savings in operational costs and addresses the security limitations of the 6PE approach. 6VPE is more like a regular IPv4 MPLS-VPN provider edge, with an addition of IPv6 support within VRF. It provides logically separate routing table entries for VPN member devices.

Components of MPLS-based 6VPE Network

  • VPN route target communities – A list of all other members of a VPN community.

  • Multiprotocol BGP (MP-BGP) peering of VPN community PE routers – Propagates VRF reachability information to all members of a VPN community.

  • MPLS forwarding – Transports all traffic between all VPN community members across a VPN service-provider network.

In the MPLS-VPN model a VPN is defined as a collection of sites sharing a common routing table. A customer site is connected to the service provider network by one or more interfaces, where the service provider associates each interface with a VPN routing table–known as the VRF table.

Configuration Examples for 6VPE

Figure 1. 6VPE Topology

PE Configuration

CE Configuration


vrf definition 6VPE-1
 rd 65001:11
 route-target export 1:1
 route-target import 1:1
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
interface TenGigabitEthernet1/0/38
 no switchport
 vrf forwarding 6VPE-1
 ip address 10.3.1.1 255.255.255.0
 ip ospf 2 area 0
 ipv6 address 10:111:111:111::1/64
 ipv6 enable
 ospfv3 1 ipv6 area 0
!
router ospf 2 vrf 6VPE-1
 router-id 1.1.11.11
 redistribute bgp 65001 subnets
!
router ospfv3 1
nsr
graceful-restart
!
address-family ipv6 unicast vrf 6VPE-1
redistribute bgp 65001
exit-address-family
!
router bgp 65001
bgp router-id interface Loopback1
bgp log-neighbor-changes
bgp graceful-restart
neighbor 33.33.33.33 remote-as 65001
neighbor 33.33.33.33 update-source Loopback1
!
 address-family ipv4 vrf 6VPE-1
  redistribute ospf 2 match internal external 1 external 2
 exit-address-family
 address-family ipv6 vrf 6VPE-1
  redistribute ospf 1 match internal external 1 external 2 include-connected
 exit-address-family
!
address-family vpnv4
neighbor 33.33.33.33 activate
neighbor 33.33.33.33 send-community both
neighbor 44.44.44.44 activate
neighbor 44.44.44.44 send-community both
neighbor 55.55.55.55 activate
neighbor 55.55.55.55 send-community both
exit-address-family
!
address-family vpnv6
neighbor 33.33.33.33 activate
neighbor 33.33.33.33 send-community both
neighbor 44.44.44.44 activate
neighbor 44.44.44.44 send-community both
neighbor 55.55.55.55 activate
neighbor 55.55.55.55 send-community both
exit-address-family
!

interface TenGigabitEthernet1/0/38
no switchport
ip address 10.3.1.2 255.255.255.0
ip ospf 2 area 0
ipv6 address 10:111:111:111::2/64
ipv6 enable
ipv6 ospf 1 area 0
!
router ospfv3 1
nsr
graceful-restart
address-family ipv6 unicast
!
The following is a sample output of show mpls forwarding-table vrf :

Local Outgoing Prefix Bytes Label Outgoing Next Hop 
Label Label or Tunnel Id Switched interface 
29 No Label A:A:A:565::/64[V] \ 0 aggregate/VRF601 
32 No Label A:B5:1:5::/64[V] 2474160 Vl601 FE80::200:7BFF:FE62:2636 
33 No Label A:B5:1:4::/64[V] 2477978 Vl601 FE80::200:7BFF:FE62:2636 
35 No Label A:B5:1:3::/64[V] 2477442 Vl601 FE80::200:7BFF:FE62:2636 
36 No Label A:B5:1:2::/64[V] 2476906 Vl601 FE80::200:7BFF:FE62:2636 
37 No Label A:B5:1:1::/64[V] 2476370 Vl601 FE80::200:7BFF:FE62:2636

The following is a sample output of show vrf counter command :

Maximum number of VRFs supported: 256 
Maximum number of IPv4 VRFs supported: 256 
Maximum number of IPv6 VRFs supported: 256 
Maximum number of platform iVRFs supported: 10 
Current number of VRFs: 127 
Current number of IPv4 VRFs: 6 
Current number of IPv6 VRFs: 127 
Current number of VRFs in delete state: 0 
Current number of platform iVRFs: 1 

The following is a sample output of show ipv6 route vrf command :

IPv6 Routing Table - VRF1 - 8 entries Codes: C - Connected, L - Local, S - Static, U - Per-user Static route B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2 IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1 OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2 la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid lA - LISP away 

B 1:1:1:1::1/128 [200/1] via 1.1.1.11%default, indirectly connected 
O 2:2:2:2::2/128 [110/1] via FE80::A2E0:AFFF:FE30:3E40, TenGigabitEthernet1/0/7 
B 3:3:3:3::3/128 [200/1] via 3.3.3.33%default, indirectly connected 
B 10:1:1:1::/64 [200/0] via 1.1.1.11%default, indirectly connected 
C 10:2:2:2::/64 [0/0] via TenGigabitEthernet1/0/7, directly connected 
L 10:2:2:2::1/128 [0/0] via TenGigabitEthernet1/0/7, receive 
B 10:3:3:3::/64 [200/0] via 3.3.3.33%default, indirectly connected 
L FF00::/8 [0/0] via Null0, receive

Feature History for IPv6 VPN Provider Edge over MPLS (6VPE)

This table provides release and related information for features explained in this module.

These features are available on all releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Everest 16.6.1

IPv6 VPN Provider Edge over MPLS (6VPE)

IPv6 VPN Provider Edge over MPLS (6VPE) is a mechanism to use the IPv4 backbone to provide VPN IPv6 services. It takes advantage of operational IPv4 MPLS backbones, eliminating the need for dual-stacking within the MPLS core.

Support for this feature was introduced only on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches.

Use Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.