Published On: July 20ᵗʰ, 2021 07:30

Multiprotocol Label Switching (MPLS) Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Configuring Virtual Private LAN Service (VPLS) requires a full mesh of tunnel label switched paths (LSPs) between all the provider edge (PE) devices that participate in the VPLS. With full-mesh configuration, signaling overhead and packet replication requirements for each provisioned virtual circuit (VC) on a PE device are high. Configuring Hierarchical VPLS with Multiprotocol Label Switching (MPLS) Access reduces signaling overhead and packet replication between devices.

Prerequisites for Configuring Hierarchical VPLS with MPLS Access

Configure the PE to customer edge (CE) interface with a list of allowed VLANs.

Restrictions for Configuring Hierarchical VPLS with MPLS Access

  • This feature is not supported on the Cisco Catalyst 9500 Series Switches.

  • This feature is not supported if VPLS Autodiscovery is configured on pseudowires (PWs) that are attached to user provider edge (U-PE) devices. (When you create the VPLS, you can manually create the virtual forwarding interface (VFI)).

  • This feature is not supported if Q-in-Q access is configured between a U-PE device and a N-PE device.

  • Internet Group Management Protocol (IGMP) snooping is not supported.

  • Cisco Discovery Protocol (CDP) is not supported.

  • Multiprotocol Label Switching (MPLS) over generic routing encapsulation (GRE) and VPLS over GRE are not supported.

Information About Configuring Hierarchical VPLS with MPLS Access

The following section provides information about configuring hierarchical VPLS with MPLS access.

About Hierarchical VPLS with MPLS Access

A standard VPLS configuration comprises CE devices and PE devices. Using the Hierarchical VPLS with MPLS Access feature, each PE device is replaced with a U-PE and an N-PE device. U-PE devices communicate with the CE devices and N-PE devices on the access side, and N-PE devices communicate with other N-PE devices on the provider core.

Figure 1 shows a hierarchical VPLS with MPLS access configuration. Each CE device is connected to a U-PE device through an attachment circuit. A U-PE device is connected to an N-PE device through a single pseudowire (PW) for each VPLS instance.

The following configuration types are supported between a U-PE device and an N-PE device:

  • Ethernet Q-in-Q


    Note

    Ethernet Q-in-Q configurations are not supported in Cisco IOS XE Amsterdam 17.2.x .


  • EoMPLS

N-PE devices are connected to each other through a mesh of PWs. Packets from a U-PE device to an N-PE device can be forwarded to other U- PE devices that are connected to the same N-PE device and to other N-PE devices, if any, because split horizon is disabled. Packets in the provider core are not forwarded back to the provider core because split horizon is enabled.

Figure 1. Hierarchical VPLS with MPLS Access Configuration

Features that Support Hierarchical VPLS with MPLS Access Configuration

The following is a list of features that support the Hierarchical VPLS with MPLS Access Configuration:

  • VPLS integrated routing and bridging (IRB)

  • VPLS MAC address withdrawal

  • PW redundancy

  • VPLS flow-aware transport PW

How to Configure Hierarchical VPLS with MPLS Access

The following sections provide information on how to configure the Hierarchical VPLS with MPLS Access feature.

Configuring VPLS (Protocol-CLI Method) on an N-PE Device

To configure VPLS (Protocol-CLI method) on an N-PE device, perform this procedure,


Note

Repeat this procedure on each N-PE device.


Procedure

  Command or Action Purpose
Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password, if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

l2vpn vfi context name

Example:

Device(config)# l2vpn vfi context vpn100

Establishes a Layer 2 VPN VFI between two or more separate networks, and enters L2VFI configuration mode.

Step 4

vpn id vpn id

Example:

Device(config-vfi)# vpn id 100

Sets a VPN ID on the VPLS instance.

  • Use the same VPN ID for the N-PE devices that belong to the same VPN.

  • Make sure that the VPN ID is unique for each VPN in the service provider network. The range is from 1 to 4294967295.

Step 5

member ip-address encapsulation mpls

Example:

Device(config-vfi)# member 4.4.4.4 encapsulation mpls

Specifies the device that forms a point-to-point L2VPN VFI connection.

  • ip-address : IP address of the VFI neighbor (the N-PE device).

  • encapsulation mpls : Specifies mpls as the data encapsulation method.

Step 6

exit

Example:

Device(config-vlan-config)# exit

Returns to global configuration mode.

Step 7

vlan configuration vlan-id

Example:

Device(config)# vlan configuration 100

Applies the configuration on the VLAN, and enters VLAN configuration mode.

Step 8

member vfi vfi-name

Example:


Device(config-vlan-config)# member vfi vpn100

Binds a VFI instance to a VLAN or an interface.

Step 9

member ip-address encapsulation mpls

Example:

Device(config-vlan-config)# member 19.19.19.19 encapsulation mpls

Specifies the device that forms a point-to-point L2VPN VFI connection.

  • ip-address : IP address of the VFI neighbor (the U-PE device).

  • encapsulation mpls : Specifies mpls as the data encapsulation method.

Step 10

end

Example:


Device(config-vlan-config)# end

Exits privileged EXEC mode.

Configuring EoMPLS VLAN (Xconnect Method) on an U-PE Device

To configure EoMPLS VLAN (Xconnect method) on an U-PE device, perform this procedure,


Note

Perform this task on each U-PE device

Procedure

  Command or Action Purpose
Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

interface interface-id.subinterface

Example:

Device(config)# interface TenGigabitEthernet1/6/21.100

Defines the subinterface to be configured, and enters subinterface configuration mode.

Step 4

encapsulation dot1q vlan-id

Example:

Device(config-subif)# encapsulation dot1q 100

Enables IEEE 802.1Q encapsulation of traffic on the subinterface.

Step 5

xconnect peer-ip-addr vc-id encapsulation mpls

Example:

Device(config-if)# xconnect 3.3.3.3 150 encapsulation mpls

Binds the attachment circuit to a PW VC. The syntax for this command is the same as for all the other Layer 2 transports.

Step 6

exit

Example:

Device(config-if)# exit

Returns to global configuration mode.

Configuration Examples for Hierarchical VPLS with MPLS Access

The following example shows how to configure loopback interface for N-PE1:

Device> enable
Device# configure terminal
Device(config)# interface loopback 0
Device(config-if)# ip address 3.3.3.3 255.255.255.255
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable MPLS on N-PE1:

Device> enable
Device# configure terminal
Device(config)# interface For 1/0/20
Device(config-if)# ip address 17.0.0.2 255.255.255.0
Device(config-if)# mpls ip
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable VFI on N-PE1:

Device> enable
Device# configure terminal
Device(config)# l2vpn vfi context vpn100
Device(config-vfi)# vpn id 100
Device(config-vfi)# member 4.4.4.4 encapsulation mpls

The following example shows how to specify a point-to-point Layer 2 VPN (L2VPN) VFI connection on N-PE1:

Device> enable
Device# configure terminal
Device(config)# vlan configuration 100
Device(config-vlan-config)# member vfi vpn100
Device(config-vlan-config)# mmember 19.19.19.19 encapsulation mpls

The following example shows how to configure loopback interface for N-PE2:

Device> enable
Device# configure terminal
Device(config)# interface loopback 0
Device(config-if)# ip address 4.4.4.4 255.255.255.255
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable MPLS on N-PE2:

Device> enable
Device# configure terminal
Device(config)# interface For 1/0/5
Device(config-if)# ip address 13.0.0.2 255.255.255.0
Device(config-if)# mpls ip
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable VFI on the N-PE2:

Device> enable
Device# configure terminal
Device(config)# l2vpn vfi context vpn100
Device(config-vfi)# vpn id 100
Device(config-vfi)# member 3.3.3.3 encapsulation mpls

The following example shows how to specify a point-to-point L2VPN VFI connection on N-PE2:

Device> enable
Device# configure terminal
Device(config)# vlan configuration 100
Device(config-vlan-config)# member vfi vpn100

The following example shows how to configure loopback interface for U-PE1:

Device> enable
Device# configure terminal
Device(config)# interface loopback 0
Device(config-if)# ip address 19.19.19.19 255.255.255.255
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable MPLS on U-PE1:

Device> enable
Device# configure terminal
Device(config)# interface Forty2/1
Device(config-if)# ip address 17.0.0.1 255.255.255.0
Device(config-if)# mpls ip
Device(config-if)# ip ospf 1 area 0
Device(config-if)# end

The following example shows how to enable EoMPLS on U-PE1:

Device> enable
Device# configure terminal
Device(config)# interface TenGig6/21.100
Device(config-if)# encapsulation dot1q 100
Device(config-if)# xconnect 3.3.3.3 100 encapsulation mpls

Feature Information for Configuring Hierarchical VPLS with MPLS Access

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Table 1. Feature Information for Hierarchical VPLS with MPLS Access

Feature Name

Releases

Feature Information

Hierarchical VPLS with MPLS Access

Cisco IOS XE Amsterdam 17.2.x

Configuring VPLS requires a full mesh of tunnel LSPs between all the PE devices that participate in the VPLS. With full-mesh configuration, signaling overhead and packet replication requirements for each provisioned VC on a PE device are high. Configuring Hierarchical VPLS with MPLS Access reduces signaling overhead and packet replication between devices.