Published On: August 10ᵗʰ, 2021 02:10

IP Multicast Routing Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Prerequisites for SSM Channel Based Filtering for Multicast Boundaries

IP multicast is enabled on the device using the tasks described in the "Configuring Basic IP Multicast" module of the IP Multicast: PIM Configuration Guide.

Information About the SSM Channel Based Filtering for Multicast Boundaries

This section provides information about the SSM channel based filtering for multicast boundaries feature.

Rules for Multicast Boundaries

The SSM Channel Based Filtering for Multicast Boundaries feature expands the ip multicast boundary command for control plane filtering support. More than one ip multicast boundary command can be applied to an interface.

The following rules govern the ip multicast boundary command:

  • One instance of the in and out keywords can be configured on an interface.

  • The in and out keywords can be used for standard or extended access lists.

  • Only standard access lists are permitted with the use of the filter-autorp keyword or no keyword.

  • A maximum of three instances of a command will be allowed on an interface: one instance of in , one instance of out , and one instance of filter-autorp or no keyword.

  • When multiple instances of the command are used, the filtering will be cumulative. If a boundary statement with no keyword exists with a boundary statement with the in keyword, both access lists will be applied on the in direction and a match on either one will be sufficient.

  • All instances of the command apply to both control and data plane traffic.

  • Protocol information on the extended access list is parsed to allow reuse and filtering for consistency. An (S,G) operation will be filtered by an extended access list under all conditions stated above for keywords if the access list filters (S,G) traffic for all protocols.

Benefits of SSM Channel Based Filtering for Multicast Boundaries

  • This feature allows input on the source interface.

  • The access control capabilities are the same for SSM and Any Source Multicast (ASM).

How to Configure SSM Channel Based Filtering for Multicast Boundaries

This section provides steps for configuring SSM channel based filtering for multicast boundaries.

Configuring Multicast Boundaries

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. ip access-list {standard | extended } access -list -name
  4. permit protocol host address host address
  5. deny protocol host address host address
  6. Repeat Step 4 or Step 5 as needed.
  7. interface type interface-number port -number
  8. ip multicast boundary access-list-name [in | out | filter-autorp ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

ip access-list {standard | extended } access -list -name

Example:


Device(config)# ip access-list 101 

Configures the standard or extended access list.

Step 4

permit protocol host address host address

Example:


Device(config-ext-nacl)# permit ip host 181.1.2.201 host 232.1.1.11 

Permits specified ip host traffic.

Step 5

deny protocol host address host address

Example:


Device(config-acl-nacl)# deny ip host 181.1.2.203 host 232.1.1.1

Denies specified multicast ip group and source traffic.

Step 6

Repeat Step 4 or Step 5 as needed.

Permits and denies specified host and source traffic.

Step 7

interface type interface-number port -number

Example:


Device(config)# interface gigabitethernet 2/3/0

Enables interface configuration mode.

Step 8

ip multicast boundary access-list-name [in | out | filter-autorp ]

Example:


Device(config-if)# ip multicast boundary acc_grp1 out

Configures the multicast boundary.

Note 

The filter-autorp keyword does not support extended access lists.

Configuration Examples for SSM Channel Based Filtering for Multicast Boundaries

This section provides configuration examples of SSM Channel Based filtering for multicast boundaries.

Configuring the Multicast Boundaries Permitting and Denying Traffic Example

The following example permits outgoing traffic for (181.1.2.201, 232.1.1.1) and (181.1.2.202, 232.1.1.1) and denies all other (S,G)s.


configure terminal
 ip access-list extended acc_grp1
 permit ip host 0.0.0.0 232.1.1.1 0.0.0.255
 permit ip host 181.1.2.201 host 232.1.1.1
 permit udp host 181.1.2.202 host 232.1.1.1
 permit ip host 181.1.2.202 host 232.1.1.1
 deny igmp host 181.2.3.303 host 232.1.1.1
 interface gigabitethernet 1/0/1
 ip multicast boundary acc_grp1 out

Configuring the Multicast Boundaries Permitting Traffic Example

The following example permits outgoing traffic for (192.168.2.201, 232.1.1.5) and 192.168.2.202, 232.1.1.5).


configure terminal
ip access-list extended acc_grp6
 permit ip host 0.0.0.0 232.1.1.1 5.0.0.255
 deny udp host 192.168.2.201 host 232.1.1.5
 permit ip host 192.168.2.201 host 232.1.1.5
 deny pim host 192.168.2.201 host 232.1.1.5
 permit ip host 192.168.2.202 host 232.1.1.5
 deny igmp host 192.2.3.303 host 232.1.1.1
interface gigabitethernet 1/0/1
 ip multicast boundary acc_grp6 out

Configuring the Multicast Boundaries Denying Traffic Example

The following example denies a group-range that is announced by the candidate RP. Because the group range is denied, no pim auto-rp mappings are created.


configure terminal
ip access-list standard acc_grp10
 deny 225.0.0.0 0.255.255.255
 permit any
 access-list extended acc_grp12
 permit pim host 181.1.2.201 host 232.1.1.8
 deny udp host 181.1.2.201 host 232.1.1.8
 permit pim host 181.1.2.203 0.0.0.255 host 227.7.7.7
 permit ip host 0.0.0.0 host 227.7.7.7
 permit ip 181.1.2.203 0.0.0.255 host 227.7.7.7
 permit ip host 181.1.2.201 host 232.1.1.7
ip access-list extended acc_grp13
 deny ip host 181.1.2.201 host 232.1.1.8
 permit ip any any
interface gigabitethernet 1/0/1
 ip multicast boundary acc_grp10 filter-autorp
 ip multicast boundary acc_grp12 out
 ip multicast boundary acc_grp13 in

Additional References for IP Multicast Optimization: SSM Channel-Based Filtering for Multicast

Related Documents

Related Topic

Document Title

For complete syntax and usage information for the commands used in this chapter.

See the IP Multicast Routing Commands section of the Command Reference (Catalyst 9500 Series Switches) .

Feature History for IP Multicast Optimization: SSM Channel Based Filtering for Multicast

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Everest 16.5.1a

IP Multicast Optimization: SSM Channel Based Filtering for Multicast

The SSM Channel Based Filtering for Multicast Boundaries feature expands the ip multicast boundary command for control plane filtering support. More than one ip multicast boundary command can be applied to an interface.

Support for this feature was introduced only on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches.

Cisco IOS XE Fuji 16.8.1a

IP Multicast Optimization: SSM Channel Based Filtering for Multicast

Support for this feature was introduced on the C9500-32C, C9500-32QC, C9500-48Y4C, and C9500-24Y4C models of the Cisco Catalyst 9500 Series Switches.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/