Published On: October 21ˢᵗ, 2021 08:40

IP Addressing Services Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Information About Configuring IPv6 over IPv4 GRE Tunnels

The following sections provide information about configuring IPv6 over IPv4 GRE tunnels:

Overlay Tunnels for IPv6

Overlay tunneling encapsulates IPv6 packets in IPv4 packets for delivery across an IPv4 infrastructure (a core network or the figure below). By using overlay tunnels, you can communicate with isolated IPv6 networks without upgrading the IPv4 infrastructure between them. Overlay tunnels can be configured between border devices or between a border device and a host; however, both tunnel endpoints must support both the IPv4 and IPv6 protocol stacks.

Figure 1. Overlay Tunnels

Note

Overlay tunnels reduce the maximum transmission unit (MTU) of an interface by 20 octets (assuming that the basic IPv4 packet header does not contain optional fields). A network that uses overlay tunnels is difficult to troubleshoot. Therefore, overlay tunnels that connect isolated IPv6 networks should not be considered a final IPv6 network architecture. The use of overlay tunnels should be considered as a transition technique toward a network that supports both the IPv4 and IPv6 protocol stacks or just the IPv6 protocol stack.


IPv6 supports GRE type of overlay tunneling. IPv6 over IPv4 GRE Tunnels can carry IPv6, Connectionless Network Service (CLNS), and many other types of packets.

GRE IPv4 Tunnel Support for IPv6 Traffic

IPv6 traffic can be carried over IPv4 GRE tunnels using the standard GRE tunneling technique that is designed to provide the services to implement any standard point-to-point encapsulation scheme. As in IPv6 manually configured tunnels, GRE tunnels are links between two points, with a separate tunnel for each link. The tunnels are not tied to a specific passenger or transport protocol but, in this case, carry IPv6 as the passenger protocol with the GRE as the carrier protocol and IPv4 or IPv6 as the transport protocol.

The primary use of GRE tunnels is for stable connections that require regular secure communication between two edge devices or between an edge device and an end system. The edge devices and the end systems must be dual-stack implementations.

Configuring GRE IPv6 Tunnels

Perform this task to configure a GRE tunnel on an IPv6 network. GRE tunnels can be configured to run over an IPv6 network layer and to transport IPv6 packets in IPv6 tunnels and IPv4 packets in IPv6 tunnels.

To configure GRE IPv6 tunnels, perform this procedure:

Before you begin

When GRE IPv6 tunnels are configured, IPv6 addresses are assigned to the tunnel source and the tunnel destination. The tunnel interface can have either IPv4 or IPv6 addresses assigned (this is not shown in the task). The host or router at each end of a configured tunnel must support both the IPv4 and IPv6 protocol stacks.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface tunnel tunnel-number
  4. ipv6 address ipv6-prefix / prefix-length [eui-64 ]
  5. tunnel source {ip-address | ipv6-address | interface-type interface-number }
  6. tunnel destination {host-name | ip-address | ipv6-address }
  7. tunnel mode {aurp | cayman | dvmrp | eon | gre | gre multipoint | gre ipv6 | ipip [decapsulate-any ] | iptalk | ipv6 | mpls | nos

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable 

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal


Enters global configuration mode.

Step 3

interface tunnel tunnel-number

Example:


Device(config)# interface tunnel 0

Specifies a tunnel interface and number, and enters interface configuration mode.

Step 4

ipv6 address ipv6-prefix / prefix-length [eui-64 ]

Example:


Device(config-if)# ipv6 address 3ffe:b00:c18:1::3/127

Specifies the IPv6 network assigned to the interface and enables IPv6 processing on the interface.

Step 5

tunnel source {ip-address | ipv6-address | interface-type interface-number }

Example:


Device(config-if)# tunnel source ethernet 0

Specifies the source IPv4 address or the source interface type and number for the tunnel interface.

  • If an interface is specified, the interface must be configured with an IPv4 address.

Step 6

tunnel destination {host-name | ip-address | ipv6-address }

Example:


Device(config-if)# tunnel destination 2001:DB8:1111:2222::1/64

Specifies the destination IPv6 address or hostname for the tunnel interface.

Step 7

tunnel mode {aurp | cayman | dvmrp | eon | gre | gre multipoint | gre ipv6 | ipip [decapsulate-any ] | iptalk | ipv6 | mpls | nos

Example:


Device(config-if)# tunnel mode gre ipv6

Specifies a GRE IPv6 tunnel.

Note 

The tunnel mode gre ipv6 command specifies GRE as the encapsulation protocol for the tunnel.

Configuration Examples for IPv6 over IPv4 GRE Tunnels

The following sections provide examples on how to configure IPv6 over IPv4 GRE tunnels:

Example: GRE Tunnel Running IS-IS and IPv6 Traffic

The following example configures a GRE tunnel running both IS-IS and IPv6 traffic between Router A and Router B:

Router A Configuration

Device> enable
Device# configure terminal
Device(config)# ipv6 unicast-routing
Device(config)# clns routing
!
Device(config)# interface tunnel 0
Device(config-if)# no ip address
Device(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
Device(config-if)# ipv6 router isis 
Device(config-if)# tunnel source Ethernet 0/0
Device(config-if)# tunnel destination 2001:DB8:1111:2222::1/64
Device(config-if)# tunnel mode gre ipv6
Device(config-if)# exit
!
Device(config)# interface Ethernet0/0
Device(config-if)# ip address 10.0.0.1 255.255.255.0
!
Device(config-if)# router isis 
Device(config-if)# net 49.0000.0000.000a.00

Router B Configuration

Device> enable
Device# configure terminal
Device(config)# ipv6 unicast-routing
Device(config)# clns routing
!
Device(config)# interface tunnel 0
Device(config-if)# no ip address
Device(config-if)# ipv6 address 3ffe:b00:c18:1::2/127
Device(config-if)# exit
Device(config)# ipv6 router isis 
Device(config-router)# tunnel source Ethernet 0/0
Device(config-router)# tunnel destination 2001:DB8:1111:2222::2/64
Device(config-router)# tunnel mode gre ipv6
Device(config-router)# exit
!
Device(config)# interface Ethernet0/0
Device(config-if)# ip address 10.0.0.2 255.255.255.0
Device(config-if)# exit
!
Device(config)# router isis 
Device(config-router)# net 49.0000.0000.000b.00
Device(config-router)# address-family ipv6
Device(config-router-af)# redistribute static
Device(config-router-af)# exit-address-family

Example: Tunnel Destination Address for IPv6 Tunnel

Device> enable
Device# configure terminal
Device(config)# interface Tunnel 0
Device(config-if)# ipv6 address 2001:1:1::1/48
Device(config-if)# tunnel source GigabitEthernet 0/0/0
Device(config-if)# tunnel destination 10.0.0.2
Device(config-if)# tunnel mode gre ipv6
Device(config-if)# exit
!
Device(config)# interface GigabitEthernet0/0/0
Device(config-if)# ip address 10.0.0.1 255.255.255.0
Device(config-if)# exit
!
Device(config)# ipv6 unicast-routing
Device(config)# router isis
Device(config-router)# net 49.0000.0000.000a.00

Additional References

Related Documents

Related Topic Document Title

For complete syntax and usage information for the commands used in this chapter.

Command Reference (Catalyst 9500 Series Switches)

Feature History for IPv6 over IPv4 GRE Tunnels

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Fuji 16.8.1a

IPv6 over IPv4 GRE Tunnels

GRE tunnels are links between two points, with a separate tunnel for each link. The tunnels are not tied to a specific passenger or transport protocol, but in this case carry IPv6 as the passenger protocol with the GRE as the carrier protocol and IPv4 or IPv6 as the transport protocol.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.