Published On: October 21ˢᵗ, 2021 08:40

IP Addressing Services Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Information About Hot Standby Router Protocol

The following sections provide information about Hot Standby Router Protocol (HSRP)

HSRP Overview

HSRP is Cisco's standard method of providing high network availability by providing first-hop redundancy for IP hosts on an IEEE 802 LAN configured with a default gateway IP address. HSRP routes IP traffic without relying on the availability of any single router. It enables a set of router interfaces to work together to present the appearance of a single virtual router or default gateway to the hosts on a LAN. When HSRP is configured on a network or segment, it provides a virtual Media Access Control (MAC) address and an IP address that is shared among a group of configured routers. HSRP allows two or more HSRP-configured routers to use the MAC address and IP network address of a virtual router. The virtual router does not exist; it represents the common target for routers that are configured to provide backup to each other. One of the routers is selected to be the active router and another to be the standby router, which assumes control of the group MAC address and IP address should the designated active router fail.


Note
Routers in an HSRP group can be any router interface that supports HSRP, including routed ports and switch virtual interfaces (SVIs).

HSRP provides high network availability by providing redundancy for IP traffic from hosts on networks. In a group of router interfaces, the active router is the router of choice for routing packets; the standby router is the router that takes over the routing duties when an active router fails or when preset conditions are met.

HSRP is useful for hosts that do not support a router discovery protocol and cannot switch to a new router when their selected router reloads or loses power. When HSRP is configured on a network segment, it provides a virtual MAC address and an IP address that is shared among router interfaces in a group of router interfaces running HSRP. The router selected by the protocol to be the active router receives and routes packets destined for the group's MAC address. For n routers running HSRP, there are n +1 IP and MAC addresses assigned.

HSRP detects when the designated active router fails, and a selected standby router assumes control of the Hot Standby group's MAC and IP addresses. A new standby router is also selected at that time. Devices running HSRP send and receive multicast UDP-based hello packets to detect router failure and to designate active and standby routers. When HSRP is configured on an interface, Internet Control Message Protocol (ICMP) redirect messages are automatically enabled for the interface.

You can configure multiple Hot Standby groups among switches and switch stacks that are operating in Layer 3 to make more use of the redundant routers.


Note

Cisco Catalyst 9500 Series Switches do not support stacking.


To do so, specify a group number for each Hot Standby command group you configure for an interface. For example, you might configure an interface on switch 1 as an active router and one on switch 2 as a standby router and also configure another interface on switch 2 as an active router with another interface on switch 1 as its standby router.

The following figure shows a segment of a network configured for HSRP. Each router is configured with the MAC address and IP network address of the virtual router. Instead of configuring hosts on the network with the IP address of Router A, you configure them with the IP address of the virtual router as their default router. When Host C sends packets to Host B, it sends them to the MAC address of the virtual router. If for any reason, Router A stops transferring packets, Router B responds to the virtual IP address and virtual MAC address and becomes the active router, assuming the active router duties. Host C continues to use the IP address of the virtual router to address packets destined for Host B, which Router B now receives and sends to Host B. Until Router A resumes operation, HSRP allows Router B to provide uninterrupted service to users on Host C's segment that need to communicate with users on Host B's segment and also continues to perform its normal function of handling packets between the Host A segment and Host B.

Figure 1. Typical HSRP Configuration

HSRP Versions

Cisco IOS XE Everest 16.5.1a and later support these Hot Standby Router Protocol (HSRP) versions:

The switch supports these HSRP versions:

  • HSRPv1- Version 1 of the HSRP, the default version of HSRP. It has these features:

    • The HSRP group number can be from 0 to 255.

    • HSRPv1 uses the multicast address 224.0.0.2 to send hello packets, which can conflict with Cisco Group Management Protocol (CGMP) leave processing. You cannot enable HSRPv1 and CGMP at the same time; they are mutually exclusive.

  • HSRPv2- Version 2 of the HSRP has these features:

    • HSRPv2 uses the multicast address 224.0.0.102 to send hello packets. HSRPv2 and CGMP leave processing are no longer mutually exclusive, and both can be enabled at the same time.

    • HSRPv2 has a different packet format than HRSPv1.

A switch running HSRPv1 cannot identify the physical router that sent a hello packet because the source MAC address of the router is the virtual MAC address.

HSRPv2 has a different packet format than HSRPv1. A HSRPv2 packet uses the type-length-value (TLV) format and has a 6-byte identifier field with the MAC address of the physical router that sent the packet.

If an interface running HSRPv1 gets an HSRPv2 packet, the type field is ignored.

Multiple HSRP

The switch supports Multiple HSRP (MHSRP), an extension of HSRP that allows load sharing between two or more HSRP groups. You can configure MHSRP to achieve load-balancing and to use two or more standby groups (and paths) from a host network to a server network.

In the figure below, half the clients are configured for Router A, and half the clients are configured for Router B. Together, the configuration for Routers A and B establishes two HSRP groups. For group 1, Router A is the default active router because it has the assigned highest priority, and Router B is the standby router. For group 2, Router B is the default active router because it has the assigned highest priority, and Router A is the standby router. During normal operation, the two routers share the IP traffic load. When either router becomes unavailable, the other router becomes active and assumes the packet-transfer functions of the router that is unavailable.


Note

For MHSRP, you need to enter the standby preempt interface configuration command on the HSRP interfaces so that if a router fails and then comes back up, preemption restores load sharing.
Figure 2. MHSRP Load Sharing

HSRP and Switch Stacks


Note

This feature is not supported on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches.


HSRP hello messages are generated by the active switch. If HSRP fails on the active switch, a flap in the HSRP active state might occur. This is because HSRP hello messages are not generated while a new active switch is elected and initialized, and the standby router might become active after the active switch fails.

Configuring HSRP for IPv6

Switches running the Network Advantage license support the Hot Standby Router Protocol (HSRP) for IPv6. HSRP provides routing redundancy for routing IPv6 traffic not dependent on the availability of any single router. IPv6 hosts learn of available routers through IPv6 neighbor discovery router advertisement messages. These messages are multicast periodically or are solicited by hosts.

An HSRP IPv6 group has a virtual MAC address that is derived from the HSRP group number and a virtual IPv6 link-local address that is, by default, derived from the HSRP virtual MAC address.

Periodic messages are sent for the HSRP virtual IPv6 link-local address when the HSRP group is active. These messages stop after a final one is sent when the group leaves the active state.


Note

When configuring HSRP for IPv6, you must enable HSRP version 2 (HSRPv2) on the interface.


HSRP IPv6 Virtual MAC Address Range

HSRP IPv6 uses a different virtual MAC address block than does HSRP for IP:

0005.73A0.0000 through 0005.73A0.0FFF (4096 addresses)

HSRP IPv6 UDP Port Number

Port number 2029 has been assigned to HSRP IPv6.

How to Configure Hot Standby Router Protocol

The following sections provide configuration information about HSRP.

Default HSRP Configuration

Table 1. Default HSRP Configuration
Feature Default Setting
HSRP version Version 1
HSRP groups None configured
Standby group number 0
Standby MAC address System assigned as: 0000.0c07.acXX, where XX is the HSRP group number
Standby priority 100
Standby delay 0 (no delay)
Standby track interface priority 10
Standby hello time 3 seconds
Standby holdtime 10 seconds

HSRP Configuration Guidelines

  • HSRPv2 and HSRPv1 are mutually exclusive. HSRPv2 is not interoperable with HSRPv1 on an interface and the reverse.

  • In the procedures, the specified interface must be one of these Layer 3 interfaces:

    • Routed port: A physical port configured as a Layer 3 port by entering the no switchport command in interface configuration mode.

    • SVI: A VLAN interface created by using the interface vlan vlan_id in global configuration mode, and by default a Layer 3 interface.

    • Etherchannel port channel in Layer 3 mode: A port-channel logical interface created by using the interface port-channel port-channel-number in global configuration mode, and binding the Ethernet interface into the channel group.

  • All Layer 3 interfaces must have IP addresses assigned to them.

  • Prior to Cisco IOS XE Gibraltar 16.11.1, HSRP millisecond timers are not supported. Starting release Cisco IOS XE Gibraltar 16.11.1, HSRP millisecond timers are supported.

Enabling HSRP

The standby ip interface configuration command activates HSRP on the configured interface. If an IP address is specified, that address is used as the designated address for the Hot Standby group. If no IP address is specified, the address is learned through the standby function. You must configure at least one Layer 3 port on the LAN with the designated address. Configuring an IP address always overrides another designated address currently in use.

When the standby ip command is enabled on an interface and proxy ARP is enabled, if the interface's Hot Standby state is active, proxy ARP requests are answered using the Hot Standby group MAC address. If the interface is in a different state, proxy ARP responses are suppressed.

SUMMARY STEPS

  1. configure terminal
  2. interface interface-id
  3. standby version { 1 | 2 }
  4. standby [ group-number] ip [ ip-address [ secondary]]
  5. end
  6. show standby [ interface-id [ group]]
  7. copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose
Step 1

configure terminal

Example:

 Switch(config)# configure terminal

Enters global configuration mode.
Step 2

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Enters interface configuration mode, and enter the Layer 3 interface on which you want to enable HSRP.

Step 3

standby version { 1 | 2 }

Example:

Switch(config-if)# standby version 1

(Optional) Configures the HSRP version on the interface.

  • 1- Selects HSRPv1.

  • 2- Selects HSRPv2.

If you do not enter this command or do not specify a keyword, the interface runs the default HSRP version, HSRP v1.

Step 4

standby [ group-number] ip [ ip-address [ secondary]]

Example:

Switch(config-if)# standby 1 ip
Creates (or enable) the HSRP group using its number and virtual IP address.
  • (Optional) group-number- The group number on the interface for which HSRP is being enabled. The range is 0 to 255; the default is 0. If there is only one HSRP group, you do not need to enter a group number.

  • (Optional on all but one interface) ip-address- The virtual IP address of the hot standby router interface. You must enter the virtual IP address for at least one of the interfaces; it can be learned on the other interfaces.

  • (Optional) secondary - The IP address is a secondary hot standby router interface. If neither router is designated as a secondary or standby router and no priorities are set, the primary IP addresses are compared and the higher IP address is the active router, with the next highest as the standby router.

Step 5

end

Example:


Switch(config-if)# end
Returns to privileged EXEC mode
Step 6

show standby [ interface-id [ group]]

Example:


Switch # show standby
Verifies the configuration of the standby groups.
Step 7

copy running-config startup-config

Example:


Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Enabling and Verifying an HSRP Group for IPv6 Operation

In this task, when you enter the standby ipv6 command, a link-local address is generated from the link-local prefix, and a modified EUI-64 format interface identifier is generated in which the EUI-64 interface identifier is created from the relevant HSRP virtual MAC address.

A link-local address is an IPv6 unicast address that can be automatically configured on any interface using the link-local prefix FE80::/10 (1111 1110 10) and the interface identifier in the modified EUI-64 format. Link-local addresses are used in the stateless autoconfiguration process. Nodes on a local link can use link-local addresses to communicate; the nodes do not need site-local or globally unique addresses to communicate.

In IPv6, a device on the link advertises in RA messages any site-local and global prefixes, and its willingness to function as a default device for the link. RA messages are sent periodically and in response to router solicitation messages, which are sent by hosts at system startup.

A node on the link can automatically configure site-local and global IPv6 addresses by appending its interface identifier (64 bits) to the prefixes (64 bits) included in the RA messages. The resulting 128-bit IPv6 addresses configured by the node are then subjected to duplicate address detection to ensure their uniqueness on the link. If the prefixes advertised in the RA messages are globally unique, then the IPv6 addresses configured by the node are also guaranteed to be globally unique. Router solicitation messages, which have a value of 133 in the Type field of the ICMP packet header, are sent by hosts at system startup so that the host can immediately autoconfigure without needing to wait for the next scheduled RA message.

To enabling and verifying an HSRP group for IPv6, perform this procedure:

Procedure

  Command or Action Purpose
Step 1

enable

Example:

Device> enable 

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing

Example:


Device(config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

  • The ipv6 unicast-routing command must be enabled for HSRP for IPv6 to work.

Step 4

interface type number

Example:


Device(config)# interface GigabitEthernet 0/0/0

Specifies an interface type and number, and places the device in interface configuration mode.

Step 5

standby [group-number ] ipv6 {link-local-address | autoconfig }

Example:


Device(config-if)# standby 1 ipv6 autoconfig

Activates the HSRP in IPv6.

Step 6

standby [group-number ] preempt [delay minimum seconds | reload seconds | sync seconds ]

Example:


Device(config-if)# standby 1 preempt

Configures HSRP preemption and preemption delay.

Step 7

standby [group-number ] priority priority

Example:


Device(config-if)# standby 1 priority 110

Configures HSRP priority.

Step 8

exit

Example:


Device(config-if)# exit

Returns the device to privileged EXEC mode.

Step 9

show standby [type number [group ]] [all | brief ]

Example:


Device# show standby

Displays HSRP information.

Step 10

show ipv6 interface [brief ] [interface-type interface-number ] [prefix ]

Example:


Device# show ipv6 interface GigabitEthernet 0/0/0

Displays the usability status of interfaces configured for IPv6.

Configuring HSRP Priority

The standby priority, standby preempt, and standby track interface configuration commands are all used to set characteristics for finding active and standby routers and behavior regarding when a new active router takes over.

When configuring HSRP priority, follow these guidelines:

  • Assigning a priority allows you to select the active and standby routers. If preemption is enabled, the router with the highest priority becomes the active router. If priorities are equal, the current active router does not change.

  • The highest number (1 to 255) represents the highest priority (most likely to become the active router).

  • When setting the priority, preempt, or both, you must specify at least one keyword (priority, preempt, or both)

  • The priority of the device can change dynamically if an interface is configured with the standby track command and another interface on the router goes down.

  • The standby track interface configuration command ties the router hot standby priority to the availability of its interfaces and is useful for tracking interfaces that are not configured for HSRP. When a tracked interface fails, the hot standby priority on the device on which tracking has been configured decreases by 10. If an interface is not tracked, its state changes do not affect the hot standby priority of the configured device. For each interface configured for hot standby, you can configure a separate list of interfaces to be tracked.

  • The standby track interface-priority interface configuration command specifies how much to decrement the hot standby priority when a tracked interface goes down. When the interface comes back up, the priority is incremented by the same amount.

  • When multiple tracked interfaces are down and interface-priority values have been configured, the configured priority decrements are cumulative. If tracked interfaces that were not configured with priority values fail, the default decrement is 10, and it is noncumulative.

  • When routing is first enabled for the interface, it does not have a complete routing table. If it is configured to preempt, it becomes the active router, even though it is unable to provide adequate routing services. To solve this problem, configure a delay time to allow the router to update its routing table.

Beginning in privileged EXEC mode, use one or more of these steps to configure HSRP priority characteristics on an interface:

SUMMARY STEPS

  1. configure terminal
  2. interface interface-id
  3. standby [ group-number] prioritypriority
  4. standby [ group-number] preempt [ delay [ minimumseconds] [ reloadseconds] [ syncseconds]]
  5. standby [ group-number] track type number [ interface-priority]
  6. end
  7. show running-config
  8. copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose
Step 1

configure terminal

Example:

Switch # configure terminal

Enters global configuration mode.

Step 2

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1
Enters interface configuration mode, and enter the HSRP interface on which you want to set priority.
Step 3

standby [ group-number] prioritypriority

Example:

Switch(config-if)# standby 120 priority 50
Sets a priority value used in choosing the active router. The range is 1 to 255; the default priority is 100. The highest number represents the highest priority.
  • (Optional) group-number—The group number to which the command applies.

Use the no form of the command to restore the default values.

Step 4

standby [ group-number] preempt [ delay [ minimumseconds] [ reloadseconds] [ syncseconds]]

Example:

Switch(config-if)# standby 1 preempt delay 300

Configures the router to preempt, which means that when the local router has a higher priority than the active router, it becomes the active router.

  • (Optional) group-number-The group number to which the command applies.

  • (Optional) delay minimum—Set to cause the local router to postpone taking over the active role for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

  • (Optional) delay reload—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload).

  • (Optional) delay sync—Set to cause the local router to postpone taking over the active role so that IP redundancy clients can reply (either with an ok or wait reply) for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

Use the no form of the command to restore the default values.

Step 5

standby [ group-number] track type number [ interface-priority]

Example:

Switch(config-if)# standby track interface gigabitethernet1/1/1
Configures an interface to track other interfaces so that if one of the other interfaces goes down, the device's Hot Standby priority is lowered.
  • (Optional) group-number- The group number to which the command applies.

  • type- Enter the interface type (combined with interface number) that is tracked.

  • number- Enter the interface number (combined with interface type) that is tracked.

  • (Optional) interface-priority- Enter the amount by which the hot standby priority for the router is decremented or incremented when the interface goes down or comes back up. The default value is 10.

Step 6

end

Example:


Switch(config-if)# end


Returns to privileged EXEC mode.
Step 7

show running-config

Verifies the configuration of the standby groups.
Step 8

copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring MHSRP

To enable MHSRP and load-balancing, you configure two routers as active routers for their groups, with virtual routers as standby routers as shown in the MHSRP Load Sharing figure in the Multiple HSRP section. You need to enter the standby preempt interface configuration command on each HSRP interface so that if a router fails and comes back up, the preemption occurs and restores load-balancing.

Router A is configured as the active router for group 1, and Router B is configured as the active router for group 2. The HSRP interface for Router A has an IP address of 10.0.0.1 with a group 1 standby priority of 110 (the default is 100). The HSRP interface for Router B has an IP address of 10.0.0.2 with a group 2 standby priority of 110.

Group 1 uses a virtual IP address of 10.0.0.3 and group 2 uses a virtual IP address of 10.0.0.4.

Configuring Router A

SUMMARY STEPS

  1. configure terminal
  2. interface type number
  3. no switchport
  4. ip address ip-address mask
  5. standby [ group-number] ip [ ip-address [ secondary]]
  6. standby [ group-number] priority priority
  7. standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]
  8. standby [ group-number] ip [ ip-address [ secondary]]
  9. standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]
  10. end
  11. show running-config
  12. copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose
Step 1

configure terminal

Example:
Switch # configure terminal
Enters global configuration mode.
Step 2

interface type number

Example:
Switch (config)# interface gigabitethernet1/0/1
Configures an interface type and enters interface configuration mode.
Step 3

no switchport

Example:
Switch (config)# no switchport
Switches an interface that is in Layer 2 mode into Layer 3 mode for Layer 3 configuration.
Step 4

ip address ip-address mask

Example:
Switch (config-if)# ip address 10.0.0.1 255.255.255.0
Specifies an IP address for an interface.
Step 5

standby [ group-number] ip [ ip-address [ secondary]]

Example:
Switch (config-if)# standby 1 ip 10.0.0.3
Creates the HSRP group using its number and virtual IP address.
  • (Optional) group-number- The group number on the interface for which HSRP is being enabled. The range is 0 to 255; the default is 0. If there is only one HSRP group, you do not need to enter a group number.

  • (Optional on all but one interface) ip-address- The virtual IP address of the hot standby router interface. You must enter the virtual IP address for at least one of the interfaces; it can be learned on the other interfaces.

  • (Optional) secondary - The IP address is a secondary hot standby router interface. If neither router is designated as a secondary or standby router and no priorities are set, the primary IP addresses are compared and the higher IP address is the active router, with the next highest as the standby router.

Step 6

standby [ group-number] priority priority

Example:
Switch(config-if)# standby 1 priority 110
Sets a priority value used in choosing the active router. The range is 1 to 255; the default priority is 100. The highest number represents the highest priority.
  • (Optional) group-number—The group number to which the command applies.

Use the no form of the command to restore the default values.

Step 7

standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]

Example:
Switch(config-if)# standby 1 preempt delay 300

Configures the router to preempt, which means that when the local router has a higher priority than the active router, it becomes the active router.

  • (Optional) group-number-The group number to which the command applies.

  • (Optional) delay minimum—Set to cause the local router to postpone taking over the active role for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

  • (Optional) delay reload—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload)

    .
  • (Optional) delay sync—Set to cause the local router to postpone taking over the active role so that IP redundancy clients can reply (either with an ok or wait reply) for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

Use the no form of the command to restore the default values.

Step 8

standby [ group-number] ip [ ip-address [ secondary]]

Example:
Switch (config-if)# standby 2 ip 10.0.0.4
Creates the HSRP group using its number and virtual IP address.
  • (Optional) group-number- The group number on the interface for which HSRP is being enabled. The range is 0 to 255; the default is 0. If there is only one HSRP group, you do not need to enter a group number.
  • (Optional on all but one interface) ip-address- The virtual IP address of the hot standby router interface. You must enter the virtual IP address for at least one of the interfaces; it can be learned on the other interfaces.
  • (Optional) secondary - The IP address is a secondary hot standby router interface. If neither router is designated as a secondary or standby router and no priorities are set, the primary IP addresses are compared and the higher IP address is the active router, with the next highest as the standby router.
Step 9

standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]

Example:
Switch(config-if)# standby 2 preempt delay 300

Configures the router to preempt, which means that when the local router has a higher priority than the active router, it becomes the active router.

  • (Optional) group-number-The group number to which the command applies.
  • (Optional) delay minimum—Set to cause the local router to postpone taking over the active role for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).
  • (Optional) delay reload—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload).
  • (Optional) delay sync—Set to cause the local router to postpone taking over the active role so that IP redundancy clients can reply (either with an ok or wait reply) for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

Use the no form of the command to restore the default values.

Step 10

end

Example:
Switch(config-if)# end
Returns to privileged EXEC mode.
Step 11

show running-config

Verifies the configuration of the standby groups.
Step 12

copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring Router B

SUMMARY STEPS

  1. configure terminal
  2. interface type number
  3. no switchport
  4. ip address ip-address mask
  5. standby [ group-number] ip [ ip-address [ secondary]]
  6. standby [ group-number] priority priority
  7. standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]
  8. standby [ group-number] ip [ ip-address [ secondary]]
  9. standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]
  10. end
  11. show running-config
  12. copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose
Step 1

configure terminal

Example:
Switch # configure terminal
Enters global configuration mode.
Step 2

interface type number

Example:
Switch (config)# interface gigabitethernet1/0/1
Configures an interface type and enters interface configuration mode.
Step 3

no switchport

Example:
Switch (config)# no switchport
Switches an interface that is in Layer 2 mode into Layer 3 mode for Layer 3 configuration.
Step 4

ip address ip-address mask

Example:
Switch (config-if)# ip address 10.0.0.2 255.255.255.0
Specifies an IP address for an interface.
Step 5

standby [ group-number] ip [ ip-address [ secondary]]

Example:
Switch (config-if)# standby 1 ip 10.0.0.3
Creates the HSRP group using its number and virtual IP address.
  • (Optional) group-number- The group number on the interface for which HSRP is being enabled. The range is 0 to 255; the default is 0. If there is only one HSRP group, you do not need to enter a group number.

  • (Optional on all but one interface) ip-address- The virtual IP address of the hot standby router interface. You must enter the virtual IP address for at least one of the interfaces; it can be learned on the other interfaces.

  • (Optional) secondary - The IP address is a secondary hot standby router interface. If neither router is designated as a secondary or standby router and no priorities are set, the primary IP addresses are compared and the higher IP address is the active router, with the next highest as the standby router.

Step 6

standby [ group-number] priority priority

Example:
Switch(config-if)# standby 2 priority 110
Sets a priority value used in choosing the active router. The range is 1 to 255; the default priority is 100. The highest number represents the highest priority.
  • (Optional) group-number—The group number to which the command applies.

Use the no form of the command to restore the default values.

Step 7

standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]

Example:
Switch(config-if)# standby 1 preempt delay 300

Configures the router to preempt, which means that when the local router has a higher priority than the active router, it becomes the active router.

  • (Optional) group-number-The group number to which the command applies.

  • (Optional) delay minimum—Set to cause the local router to postpone taking over the active role for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

  • (Optional) delay reload—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload).

  • (Optional) delay sync—Set to cause the local router to postpone taking over the active role so that IP redundancy clients can reply (either with an ok or wait reply) for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

Use the no form of the command to restore the default values.

Step 8

standby [ group-number] ip [ ip-address [ secondary]]

Example:
Switch (config-if)# standby 2 ip 10.0.0.4
Creates the HSRP group using its number and virtual IP address.
  • (Optional) group-number- The group number on the interface for which HSRP is being enabled. The range is 0 to 255; the default is 0. If there is only one HSRP group, you do not need to enter a group number.

  • (Optional on all but one interface) ip-address- The virtual IP address of the hot standby router interface. You must enter the virtual IP address for at least one of the interfaces; it can be learned on the other interfaces.

  • (Optional) secondary - The IP address is a secondary hot standby router interface. If neither router is designated as a secondary or standby router and no priorities are set, the primary IP addresses are compared and the higher IP address is the active router, with the next highest as the standby router.

Step 9

standby [ group-number] preempt [ delay [ minimum seconds] [ reload seconds] [ sync seconds]]

Example:
Switch(config-if)# standby 2 preempt delay 300

Configures the router to preempt, which means that when the local router has a higher priority than the active router, it becomes the active router.

  • (Optional) group-number-The group number to which the command applies.

  • (Optional) delay minimum—Set to cause the local router to postpone taking over the active role for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over)

    .
  • (Optional) delay reload—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload).

  • (Optional) delay sync—Set to cause the local router to postpone taking over the active role so that IP redundancy clients can reply (either with an ok or wait reply) for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over).

Use the no form of the command to restore the default values.

Step 10

end

Example:
Switch(config-if)# end
Returns to privileged EXEC mode.
Step 11

show running-config

Verifies the configuration of the standby groups.
Step 12

copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring HSRP Authentication and Timers

You can optionally configure an HSRP authentication string or change the hello-time interval and holdtime.

When configuring these attributes, follow these guidelines:

  • The authentication string is sent unencrypted in all HSRP messages. You must configure the same authentication string on all routers and access servers on a cable to ensure interoperation. Authentication mismatch prevents a device from learning the designated Hot Standby IP address and timer values from other routers configured with HSRP.

  • Routers or access servers on which standby timer values are not configured can learn timer values from the active or standby router. The timers configured on an active router always override any other timer settings.

  • All routers in a Hot Standby group should use the same timer values. Normally, the holdtime is greater than or equal to 3 times the hellotime.

Beginning in privileged EXEC mode, use one or more of these steps to configure HSRP authentication and timers on an interface:

SUMMARY STEPS

  1. configure terminal
  2. interface interface-id
  3. standby [ group-number] authentication string
  4. standby [ group-number] timers[ msec] hellotime [ msec] holdtime
  5. end
  6. show running-config
  7. copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose
Step 1

configure terminal

Example:

Switch # configure terminal

Enters global configuration mode.

Step 2

interface interface-id

Example:

Switch(config) # interface gigabitethernet1/0/1
Enters interface configuration mode, and enter the HSRP interface on which you want to set priority.
Step 3

standby [ group-number] authentication string

Example:

Switch(config-if) # standby 1 authentication word
(Optional) authentication string—Enter a string to be carried in all HSRP messages. The authentication string can be up to eight characters in length; the default string is cisco.

(Optional) group-number—The group number to which the command applies.

Step 4

standby [ group-number] timers[ msec] hellotime [ msec] holdtime

Example:

Switch(config-if) # standby 1 timers 5 15

(Optional) Configure the time between hello packets and the time before other routers declare the active router to be down.

  • group-number—The group number to which the command applies.

  • msec —The interval in milliseconds.

    Note 

    The msec keyword is supported beginning from Cisco IOS XE Gibraltar 16.11.1

    Cisco recommends to configure a minimum hello-time value of 250 milliseconds and a minimum hold-time value of 800 milliseconds.

  • hellotime —Set the interval between successive hello packets in seconds. The range is 1 to 255 seconds. The default is 3.

  • holdtime—Set to cause the local router to postpone taking over the active role after a reload for the number of seconds shown. The range is 0 to 3600 seconds (1 hour); the default is 0 (no delay before taking over after a reload).

Step 5

end

Example:


Switch(config-if) # end


Returns to privileged EXEC mode.
Step 6

show running-config

Verifies the configuration of the standby groups.
Step 7

copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Enabling HSRP Support for ICMP Redirect Messages

ICMP redirect messages are automatically enabled on interfaces configured with HSRP. ICMP is a network layer Internet protocol that provides message packets to report errors and other information relevant to IP processing. ICMP provides diagnostic functions, such as sending and directing error packets to the host. This feature filters outgoing ICMP redirect messages through HSRP, in which the next hop IP address might be changed to an HSRP virtual IP address. For more information, see the Cisco IOS IP Configuration Guide, Release 12.4.

Configuring HSRP Groups and Clustering

This feature is not supported on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches. When a device is participating in an HSRP standby routing and clustering is enabled, you can use the same standby group for command switch redundancy and HSRP redundancy. Use the cluster standby-group HSRP-group-name [routing-redundancy] global configuration command to enable the same HSRP standby group to be used for command switch and routing redundancy. If you create a cluster with the same HSRP standby group name without entering the routing-redundancy keyword, HSRP standby routing is disabled for the group.

Verifying HSRP Configurations

From privileged EXEC mode, use this command to display HSRP settings:

show standby [ interface-id [ group]] [ brief] [ detail]

You can display HSRP information for the whole switch, for a specific interface, for an HSRP group, or for an HSRP group on an interface. You can also specify whether to display a concise overview of HSRP information or detailed HSRP information. The default display is detail . If there are a large number of HSRP groups, using the show standby command without qualifiers can result in an unwieldy display.

Example

Switch #show standby
VLAN1 - Group 1
Local state is Standby, priority 105, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.182
Hot standby IP address is 172.20.128.3 configured
Active router is 172.20.128.1 expires in 00:00:09
Standby router is local
Standby virtual mac address is 0000.0c07.ac01
Name is bbb

VLAN1 - Group 100
Local state is Standby, priority 105, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.262
Hot standby IP address is 172.20.138.51 configured
Active router is 172.20.128.1 expires in 00:00:09
Active router is local
Standby router is unknown expired
Standby virtual mac address is 0000.0c07.ac64
Name is test

Configuration Examples for Hot Standby Router Protocol

The following sections provide various configuration examples for HSRP.

Enabling HSRP: Example

This example shows how to activate HSRP for group 1 on an interface. The IP address used by the hot standby group is learned by using HSRP.


Note

This procedure is the minimum number of steps required to enable HSRP. Other configurations are optional.
Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 ip
Switch(config-if)# end
Switch # show standby

Example: Configuration and Verification for an HSRP Group

The following example shows configuration and verification for an HSRP group for IPv6 that consists of Device1 and Device2. The show standby command is issued for each device to verify the device's configuration:

Device 1 configuration

interface FastEthernet0/0.100
description DATA VLAN for PCs 
encapsulation dot1Q 100 
ipv6 address 2001:DB8:CAFE:2100::BAD1:1010/64 
standby version 2 
standby 101 priority 120 
standby 101 preempt delay minimum 30 
standby 101 authentication ese 
standby 101 track Serial0/1/0.17 90 
standby 201 ipv6 autoconfig 
standby 201 priority 120 
standby 201 preempt delay minimum 30 
standby 201 authentication ese 
standby 201 track Serial0/1/0.17 90 
Device1# show standby
FastEthernet0/0.100 - Group 101 (version 2) 
State is Active 
2 state changes, last state change 5w5d 
Active virtual MAC address is 0000.0c9f.f065 
Local virtual MAC address is 0000.0c9f.f065 (v2 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.296 secs 
Authentication text "ese"
Preemption enabled, delay min 30 secs 
Active router is local 
Priority 120 (configured 120)
Track interface Serial0/1/0.17 state Up decrement 90 
IP redundancy name is "hsrp-Fa0/0.100-101" (default) 
FastEthernet0/0.100 - Group 201 (version 2) 
State is Active 
2 state changes, last state change 5w5d 
Virtual IP address is FE80::5:73FF:FEA0:C9 
Active virtual MAC address is 0005.73a0.00c9 
Local virtual MAC address is 0005.73a0.00c9 (v2 IPv6 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 2.428 secs 
Authentication text "ese" 
Preemption enabled, delay min 30 secs 
Active router is local 
Standby router is FE80::20F:8FFF:FE37:3B70, priority 100 (expires in 7.856 sec) 
Priority 120 (configured 120) 
Track interface Serial0/1/0.17 state Up decrement 90 
IP redundancy name is "hsrp-Fa0/0.100-201" (default)

Device 2 configuration

interface FastEthernet0/0.100
description DATA VLAN for Computers 
encapsulation dot1Q 100
ipv6 address 2001:DB8:CAFE:2100::BAD1:1020/64 
standby version 2 
standby 101 preempt 
standby 101 authentication ese 
standby 201 ipv6 autoconfig 
standby 201 preempt 
standby 201 authentication ese
Device2# show standby
FastEthernet0/0.100 - Group 101 (version 2) 
State is Standby 
7 state changes, last state change 5w5d 
Active virtual MAC address is 0000.0c9f.f065 
Local virtual MAC address is 0000.0c9f.f065 (v2 default) 
Hello time 3 sec, hold time 10 sec 
Next hello sent in 0.936 secs 
Authentication text "ese" 
Preemption enabled 
MAC address is 0012.7fc6.8f0c 
Standby router is local 
Priority 100 (default 100) 
IP redundancy name is "hsrp-Fa0/0.100-101" (default) 
FastEthernet0/0.100 - Group 201 (version 2) 
State is Standby 
7 state changes, last state change 5w5d
Virtual IP address is FE80::5:73FF:FEA0:C9
Active virtual MAC address is 0005.73a0.00c9 
Local virtual MAC address is 0005.73a0.00c9 (v2 IPv6 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.936 secs 
Authentication text "ese" 
Preemption enabled 
Active router is FE80::212:7FFF:FEC6:8F0C, priority 120 (expires in 7.548 sec) 
MAC address is 0012.7fc6.8f0c 
Standby router is local 
Priority 100 (default 100) 
IP redundancy name is "hsrp-Fa0/0.100-201" (default)

Configuring HSRP Priority: Example

This example activates a port, sets an IP address and a priority of 120 (higher than the default value), and waits for 300 seconds (5 minutes) before attempting to become the active router:

Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# standby ip 172.20.128.3
Switch(config-if)# standby priority 120 preempt delay 300
Switch(config-if)# end
Switch # show standby

Configuring MHSRP: Example

This example shows how to enable the MHSRP configuration shown in the figure MHSRP Load Sharing

Router A Configuration

Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.1 255.255.255.0
Switch(config-if)# standby ip 10.0.0.3
Switch(config-if)# standby 1 priority 110
Switch(config-if)#  standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)#  standby 2 preempt
Switch(config-if)# end

Router B Configuration

Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.2 255.255.255.0
Switch(config-if)# standby ip 10.0.0.3
Switch(config-if)#  standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 priority 110
Switch(config-if)#  standby 2 preempt
Switch(config-if)# end

Configuring HSRP Authentication and Timer: Example

This example shows how to configure word as the authentication string required to allow Hot Standby routers in group 1 to interoperate:

Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 authentication word
Switch(config-if)# end

This example shows how to set the timers on standby group 1 with the time between hello packets at 5 seconds and the time after which a router is considered down to be 15 seconds:

Switch # configure terminal
Switch(config) # interface gigabitethernet1/0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 ip
Switch(config-if)# standby 1 timers 5 15
Switch(config-if)# end

Configuring HSRP Groups and Clustering: Example

This example shows how to bind standby group my_hsrp to the cluster and enable the same HSRP group to be used for command switch redundancy and router redundancy. The command can only be executed on the cluster command switch. If the standby group name or number does not exist, or if the switch is a cluster member switch, an error message appears.

Switch # configure terminal
Switch(config) # cluster standby-group my_hsrp routing-redundancy
Switch(config-if)# end

Additional References for Configuring HSRP

Related Documents

Related Topic Document Title

For complete syntax and usage information for the commands used in this chapter.

Command Reference (Catalyst 9500 Series Switches)

Standards and RFCs

Standard/RFC Title

RFC 2281

Cisco Hot Standby Router Protocol

Feature History for HSRP

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Everest 16.5.1a

HSRP

HSRP is Cisco's standard method of providing high network availability by providing first-hop redundancy for IP hosts on an IEEE 802 LAN configured with a default gateway IP address.

Support for this feature was introduced only on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches.

Cisco IOS XE Fuji 16.8.1a

HSRP

Support for this feature was introduced only on the C9500-32C, C9500-32QC, C9500-48Y4C, and C9500-24Y4C models of the Cisco Catalyst 9500 Series Switches.

Cisco IOS XE Fuji 16.8.1a

HSRP for IPv6

HSRP is an FHRP designed to allow for transparent failover of the first-hop IPv6 router.

Cisco IOS XE Gibraltar 16.11.1

HSRP Timers

Support for HSRP millisecond timers was introduced.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.