Published On: September 6ᵗʰ, 2021 08:11

Interface and Hardware Components Configuration Guide, Cisco IOS XE Amsterdam 17.3.x (Catalyst 9500 Switches)

Contents

Prerequisites for Ethernet Management Port

When connecting a PC to the Ethernet management port, you must first assign an IP address.

Information About the Ethernet Management Port

The Ethernet management port, also referred to as the Gi0/0 or GigabitEthernet0/0 port, is a VRF (VPN routing/forwarding) interface to which you can connect a PC. You can use the Ethernet management port instead of the device console port for network management.

Ethernet Management Port Direct Connection to a Device

Figure 1. Connecting a Device to a PC. This figure displays how to connect the Ethernet management port to the PC for a device or a standalone device.

Ethernet Management Port and Routing

By default, the Ethernet management port is enabled. The device cannot route packets from the Ethernet management port to a network port, and the reverse. Even though the Ethernet management port does not support routing, you may need to enable routing protocols on the port.

Figure 2. Network Example with Routing Protocols Enabled. Enable routing protocols on the Ethernet management port when the PC is multiple hops away from the device and the packets must pass through multiple Layer 3 devices to reach the PC.

In the above figure, if the Ethernet management port and the network ports are associated with the same routing process, the routes are propagated as follows:

  • The routes from the Ethernet management port are propagated through the network ports to the network.

  • The routes from the network ports are propagated through the Ethernet management port to the network.

Because routing is not supported between the Ethernet management port and the network ports, traffic between these ports cannot be sent or received. If this happens, data packet loops occur between the ports, which disrupt the device and network operation. To prevent the loops, configure route filters to avoid routes between the Ethernet management port and the network ports.

Supported Features on the Ethernet Management Port

The Ethernet management port supports these features:

  • Express Setup (only in device stacks)

  • Network Assistant

  • Telnet with passwords

  • TFTP

  • Secure Shell (SSH)

  • DHCP-based autoconfiguration

  • SNMP (only the ENTITY-MIB and the IF-MIB)

  • IP ping

  • Interface features

    • Speed—10 Mb/s, 100 Mb/s, 1000 Mb/s, and autonegotiation

    • Duplex mode—Full, half, and autonegotiation

    • Loopback detection

  • Cisco Discovery Protocol (CDP)

  • DHCP relay agent

  • IPv4 and IPv6 access control lists (ACLs)


Caution

Before enabling a feature on the Ethernet management port, make sure that the feature is supported. If you try to configure an unsupported feature on the Ethernet Management port, the feature might not work properly, and the device might fail.


How to Configure the Ethernet Management Port

Disabling and Enabling the Ethernet Management Port

Procedure

  Command or Action Purpose
Step 1

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 2

interface gigabitethernet0/0

Example:

Device(config)# interface gigabitethernet0/0

Specifies the Ethernet management port in the CLI.

Step 3

shutdown

Example:

Device(config-if)# shutdown

Disables the Ethernet management port.

Step 4

no shutdown

Example:

Device(config-if)# no shutdown

Enables the Ethernet management port.

Step 5

exit

Example:

Device(config-if)# exit

Exits interface configuration mode.

Step 6

show interfaces gigabitethernet0/0

Example:

Device# show interfaces gigabitethernet0/0

Displays the link status.

To find out the link status to the PC, you can monitor the LED for the Ethernet management port. The LED is green (on) when the link is active, and the LED is off when the link is down. The LED is amber when there is a POST failure.

What to do next

Proceed to manage or configure your device using the Ethernet management port. See the Network Management section.

Example for Configuring IP Address on Ethernet Management Interface

This example shows how to configure IP address on the GigabitEthernet0/0 management interface.

Device# configure terminal
Device(config)# interface gigabitethernet0/0 
Device(config-if)# vrf forwarding Mgmt-vrf
Device(config-if)#ip address 192.168.247.10 255.255.0.0
Device(config-if)# end


Device# show running-config interface Gi0/0
Building configuration...

Current configuration : 118 bytes
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
ip address 192.168.247.10 255.255.0.0
negotiation auto
end

This example shows how to configure IP address on the TenGigabitEthernet0/1 management interface.

Device# configure terminal
Device(config)# interface TenGigabitEthernet0/1 
Device(config-if)# vrf forwarding Mgmt-vrf
Device(config-if)#ip address 192.168.247.20 255.255.0.0
Device(config-if)# negotiation auto
Device(config-if)# end


Device#show running-config interface Te0/1
Building configuration...

Current configuration : 118 bytes
!
interface TenGigabitEthernet0/1
 vrf forwarding Mgmt-vrf
 ip address 192.168.247.20 255.255.0.0
 negotiation auto
end

Additional References for Ethernet Management Port

Related Documents

Related Topic Document Title
Bootloader configuration

See the System Management section of this guide.

Bootloader commands

See the System Management Commands section of the Command Reference (Catalyst 9500 Series Switches)

Feature History for Ethernet Management Port

This table provides release and related information for features explained in this module.

These features are available on all releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Everest 16.5.1a

Ethernet Management Port

The Ethernet management port is a VRF interface to which you can connect a PC. You can use the Ethernet management port instead of the device console port for network management.

Support for this feature was introduced only on the C9500-12Q, C9500-16X, C9500-24Q, C9500-40X models of the Cisco Catalyst 9500 Series Switches.

Cisco IOS XE Fuji 16.8.1a

Ethernet Management Port

Support for this feature was introduced only on the C9500-32C, C9500-32QC, C9500-48Y4C, and C9500-24Y4C models of the Cisco Catalyst 9500 Series Switches.

Use Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.