Published On: August 6ᵗʰ, 2019 02:03

MPLS Layer 2 VPNs Configuration Guide, Cisco IOS XE Release 3S

The Frame Relay over L2TPv3 (FRoL2TPv3) feature enables Frame Relay switching over Layer 2 Tunnel Protocol Version 3 (L2TPv3). The feature works with like interfaces and disparate interfaces (L2VPN interworking).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Configuring Frame Relay over L2TPv3

Before configuring Frame Relay over L2TPv3, you should understand how to configure Layer 2 VPNs and Frame Relay. See the Additional References for pointers to the feature modules that explain how to configure and use Layer 2 VPNs and Frame Relay.

Restrictions for Configuring Frame Relay over L2TPv3

The following functionalities are not supported:

  • Frame Relay to 802.1Q/QinQ VLAN interworking
  • Frame Relay-to-Ethernet routed interworking
  • Frame Relay port-to-port switching
  • L2TPv3 pseudowire redundancy for Frame Relay

Information About Configuring Frame Relay over L2TPv3

Frame Relay over L2TPv3 Overview

Frame Relay over L2TPv3 enables provider edge (PE) devices to forward Frame Relay frames to pseudowires based on the receiving interface and the Data-Link Connection Identifier (DLCI) number. PE devices also provide Local Management Interface (LMI)-based signaling to customer edge (CE) devices, emulating Frame Relay switches.

In Frame Relay over L2TPv3, the Frame Relay header is retained at the ingress PE device. The device does not reconstruct the Frame Relay header before forwarding packets to the CE device.

The figure below shows a Frame Relay over L2TPv3 topology.

Figure 1. Frame Relay over L2TPv3



Frame Relay over L2TPv3 supports the following functionalities:

  • Frame Relay data-link connection identifier (DLCI)-to-Frame Relay DLCI
  • Frame Relay DLCI-to-Ethernet port / 802.1Q / QinQ bridged interworking
  • Local Management Interface (LMI)
  • L2TPv3 sequencing
  • L2TPv3 tunnel marking

How to Configure Frame Relay over L2TPv3

Configuring Frame Relay over L2TPv3 without LMI

This section explains how to configure Frame Relay over L2TPv3 without enabling Local Management Interface (LMI).

On CE1

The CE1 device receives the Frame Relay frames forwarded by the PE1 device over the Frame Relay link. On CE1, configure an interface and a DLCI number based on which the PE1 device forwards traffic to the appropriate pseudowire.
SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no ip address [ip-address mask] [secondary]

5. encapsulation frame-relay [cisco | ietf]

6. no keepalive

7. frame-relay intf-type dce

8. exit

9. interface type number point-to-point

10. ip address ip-address mask

11. frame-relay interface-dlci dlci

12. end


DETAILED STEPS
  Command or Action Purpose
Step 1 enable


Example:
Device> enable
 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2 configure terminal


Example:
Device# configure terminal
 

Enters global configuration mode.

 
Step 3 interface type number


Example:
Device(config)# interface serial3/1/0
 

Specifies a serial interface and enters interface configuration mode.

 
Step 4 no ip address [ip-address mask] [secondary]


Example:
Device(config-if)# no ip address 
 

Disables IP processing.

 
Step 5 encapsulation frame-relay [cisco | ietf]


Example:
Device(config-if)# encapsulation frame-relay ietf 
 

Specifies Frame Relay encapsulation for the interface.

  • You can specify different types of encapsulations.
  • You can set one interface to Cisco encapsulation and the other interface to IETF encapsulation.
 
Step 6 no keepalive


Example:
Device(config-if)# no keepalive
 

Disables the keepalive configuration.

 
Step 7 frame-relay intf-type dce


Example:
Device(config-if)# frame-relay intf-type dce
 

Specifies that the interface is a DCE switch.

  • You can also specify the interface to support Network-to-Network Interface (NNI) and DTE connections.
 
Step 8 exit


Example:
Device(config-if)# exit
 

Exits interface configuration mode and returns to global configuration mode.

 
Step 9 interface type number point-to-point


Example:
Device(config)# interface serial 3/1/0.1 point-to-point
 

Specifies a serial interface and enters interface configuration mode.

 
Step 10 ip address ip-address mask


Example:
Device(config-if)# ip address 198.51.100.2 255.255.255.0
 

Sets a primary or secondary IP address for an interface.

 
Step 11 frame-relay interface-dlci dlci


Example:
Device(config-if)# frame-relay interface-dlci 25
 

Assigns a data-link connection identifier (DLCI) to the Frame Relay interface.

 
Step 12 end


Example:
Device(config-if)# end
 

Exits interface configuration mode and returns to privileged EXEC mode.

After configuring CE1, you can configure CE2 in a similar manner.

 

On PE1

The PE1 device forwards Frame Relay frames to the appropriate pseudowire, based on the receiving interface and DLCI number configured on the CE1 device.
SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no ip address [ip-address mask] [secondary]

5. encapsulation frame-relay [cisco | ietf]

6. no keepalive

7. pseudowire-class [pw-class-name]

8. encapsulation l2tpv3

9. ip local interface loopback loopback id

10. connect connection-name interface dlci l2transport

11. xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3

12. end


DETAILED STEPS
  Command or Action Purpose
Step 1 enable


Example:
Device> enable
 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2 configure terminal


Example:
Device# configure terminal
 

Enters global configuration mode.

 
Step 3 interface type number


Example:
Device(config)# interface serial3/1/0
 

Specifies a serial interface and enters interface configuration mode.

 
Step 4 no ip address [ip-address mask] [secondary]


Example:
Device(config-if)# no ip address 
 

Disables IP processing.

 
Step 5 encapsulation frame-relay [cisco | ietf]


Example:
Device(config-if)# encapsulation frame-relay ietf 
 

Specifies Frame Relay encapsulation for the interface.

  • You can specify different types of encapsulations.
  • You can set one interface to Cisco encapsulation and the other interface to IETF encapsulation.
 
Step 6 no keepalive


Example:
Device(config-if)# no keepalive
 

Disables the keepalive configuration.

 
Step 7 pseudowire-class [pw-class-name]


Example:
Device(config)# pseudowire-class l2tpv3
 

Specifies the name of a Layer 2 pseudowire class and enters pseudowire class configuration mode.

 
Step 8 encapsulation l2tpv3


Example:
Device(config-pw)# encapsulation l2tpv3 
 

Specifies the tunneling encapsulation as L2TPv3.

 
Step 9 ip local interface loopback loopback id


Example:
Device(config-pw)# ip local interface Loopback0
 

Specifies the local loopback interface on PE1 for the L2TPv3 tunnel.

 
Step 10 connect connection-name interface dlci l2transport


Example:
Device(config)# connect fr1 serial5/0 1000 l2transport
 

Defines connections between Frame Relay Permanent Virtual Circuits (PVCs) and enters connect configuration mode.

  • Using the l2transport keyword specifies that the PVC is not a locally switched PVC, but is tunneled over the backbone network.
  • The connection-name argument is a text string that you provide.
  • The interface argument is the interface on which a PVC connection is defined.
  • The dlci argument is the DLCI number of the PVC that is connected.
 
Step 11 xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3


Example:
Device(config-xconnect-conn-config)# xconnect 198.51.100.2 123 encapsulation l2tpv3 pw-class l2tpv3
 

Creates the VC to transport the Layer 2 packets.

  • In a DLCI-to DLCI connection type, Frame Relay over L2TPv3 uses the xconnect command in connect configuration mode.
  • The vcid or identifier of the virtual circuit (VC) between the PE devices should be the same on both devices that are being connected.
 
Step 12 end


Example:
Device(config-xconnect-conn-config)# end
 

Exits connect configuration mode and returns to privileged EXEC mode.

After configuring PE1, you can configure PE2 in a similar manner.

 

Configuring Frame Relay over L2TPv3 with LMI

This section explains how to configure Frame Relay over L2TPv3 with Local Management Interface (LMI) enabled.

On CE1

The CE1 device receives the Frame Relay frames forwarded by the PE1 device over the Frame Relay link. On CE1, configure an interface and a DLCI number based on which the PE1 device forwards traffic to the appropriate pseudowire. Local Management Interface (LMI) is also tunneled over the pseudowire. Therefore, you need to properly configure the customer edge (CE) device for LMI.
SUMMARY STEPS

1. enable

2. configure terminal

3. interface serial slot/subslot /port [. subinterface]

4. no ip address [ip-address mask] [secondary]

5. encapsulation frame-relay [cisco | ietf]

6. frame-relay intf-type dce

7. end


DETAILED STEPS
  Command or Action Purpose
Step 1 enable


Example:
Device> enable
 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2 configure terminal


Example:
Device# configure terminal
 

Enters global configuration mode.

 
Step 3 interface serial slot/subslot /port [. subinterface]


Example:
Device(config)# interface serial3/1/0
 

Specifies a serial interface and enters interface configuration mode.

 
Step 4 no ip address [ip-address mask] [secondary]


Example:
Device(config-if)# no ip address 
 

Disables IP processing.

 
Step 5 encapsulation frame-relay [cisco | ietf]


Example:
Device(config-if)# encapsulation frame-relay ietf 
 

Specifies Frame Relay encapsulation for the interface.

  • You can specify different types of encapsulations.
  • You can set one interface to Cisco encapsulation and the other interface to IETF encapsulation.
 
Step 6 frame-relay intf-type dce


Example:
Device(config-if)# frame-relay intf-type dce
 

Specifies that the interface is a Data Communications Equipment (DCE) switch.

  • You can also specify the interface to support Network-to-Network Interface (NNI) and Data Transmission Equipment (DTE) connections.
 
Step 7 end


Example:
Device(config-if)# end
 

Exits interface configuration mode and returns to privileged EXEC mode.

After configuring CE1, you can configure CE2 in a similar manner.

 

On PE1

The PE1 device forwards Frame Relay frames to the CE1 device over the Frame Relay link. The PE1 device also provides Local Management Interface (LMI) signaling to the CE1 device.
SUMMARY STEPS

1. enable

2. configure terminal

3. interface serial slot/subslot/port [. subinterface]

4. encapsulation frame-relay [cisco | ietf]

5. pseudowire-class [pw-class-name]

6. encapsulation l2tpv3

7. ip local interface loopback loopback id

8. connect connection-name interface dlci l2transport

9. xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3

10. end


DETAILED STEPS
  Command or Action Purpose
Step 1 enable


Example:
Device> enable
 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2 configure terminal


Example:
Device# configure terminal
 

Enters global configuration mode.

 
Step 3 interface serial slot/subslot/port [. subinterface]


Example:
Device(config)# interface serial3/1/0
 

Specifies a serial interface and enters interface configuration mode.

 
Step 4 encapsulation frame-relay [cisco | ietf]


Example:
Device(config-if)# encapsulation frame-relay ietf 
 

Specifies Frame Relay encapsulation for the interface.

  • You can specify different types of encapsulations.
  • You can set one interface to Cisco encapsulation and the other interface to IETF encapsulation.
 
Step 5 pseudowire-class [pw-class-name]


Example:
Device(config)# pseudowire-class l2tpv3
 

Specifies the name of a Layer 2 pseudowire class and enters pseudowire class configuration mode.

 
Step 6 encapsulation l2tpv3


Example:
Device(config-pw)# encapsulation l2tpv3 
 

Specifies the tunneling encapsulation as L2TPv3.

 
Step 7 ip local interface loopback loopback id


Example:
Device(config-pw)# ip local interface Loopback0
 

Specifies the local loopback interface.

 
Step 8 connect connection-name interface dlci l2transport


Example:
Device(config)# connect fr1 serial5/0 1000 l2transport
 

Defines connections between Frame Relay Permanent Virtual Circuits (PVCs) and enters connect configuration mode.

  • Using the l2transport keyword specifies that the PVC is not a locally switched PVC, but is tunneled over the backbone network.
  • The connection-name argument is a text string that you provide.
  • The interface argument is the interface on which a PVC connection is defined.
  • The dlci argument is the DLCI number of the PVC that is connected.
 
Step 9 xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3


Example:
Device(config-fr-pw-switching)# xconnect 198.51.100.2 123 encapsulation l2tpv3 pw-class l2tpv3
 

Creates the virtual circuit (VC) to transport the Layer 2 packets.

  • In a DLCI-to-DLCI connection type, Frame Relay over L2TPv3 uses the xconnect command in connect configuration mode.
 
Step 10 end


Example:
Device(config-fr-pw-switching)# end
 

Exits connect configuration mode and returns to privileged EXEC mode.

After configuring PE1, you can configure PE2 in a similar manner.

 

Configuring Frame Relay L2TPv3 Tunnel Marking

L2TPv3 Tunnel Marking introduces the capability to define and control the quality of service (QoS) for incoming customer traffic on the provider edge (PE) device in a service provider network.

SUMMARY STEPS

1. enable

2. configure terminal

3. class-map class-name

4. match fr-dlci dlci-number

5. policy-map dlci dlci-number

6. class class-name

7. set ip precedence tunnel precedence-value

8. interface serial slot/subslot/port [. subinterface]

9. no ip address [ip-address mask] [secondary]

10. encapsulation frame-relay [cisco | ietf]

11. no keepalive

12. service-policy input policy-name

13. end

14. pseudowire-class [pw-class-name]

15. encapsulation l2tpv3

16. ip local interface loopback loopback id

17. connect connection-name interface dlci l2transport

18. xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3

19. end


DETAILED STEPS
  Command or Action Purpose
Step 1 enable


Example:
Device> enable
 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2 configure terminal


Example:
Device# configure terminal
 

Enters global configuration mode.

 
Step 3 class-map class-name


Example:
Device(config)# class-map class1 
 

Specifies the user-defined name of the traffic class and enters class map configuration mode.

 
Step 4 match fr-dlci dlci-number


Example:
Device(config-cmap)# match fr-dlci 50
 

Specifies the number of the Data-Link Connection Identifier (DLCI) associated with the packet as a match criterion in the class map.

 
Step 5 policy-map dlci dlci-number


Example:
Device(config-cmap)# policy-map dlci 50 
 

Specifies the type of policy map as DLCI and enters policy map configuration mode.

 
Step 6 class class-name


Example:
Device(config-pmap)# class class1
 

Specifies the name of a predefined traffic class, which was configured with the class-map command, used to classify traffic to the traffic policy and enters policy-map class configuration mode.

 
Step 7 set ip precedence tunnel precedence-value


Example:
Device(config-pmap-c)# set ip precedence tunnel 2
 

Sets the precedence value in the header of the L2TPv3 tunneled packet for tunnel marking.

 
Step 8 interface serial slot/subslot/port [. subinterface]


Example:
Device(config-pmap-c)# interface serial3/1/0
 

Specifies a serial interface and enters interface configuration mode.

 
Step 9 no ip address [ip-address mask] [secondary]


Example:
Device(config-if)# no ip address 
 

Disables IP processing.

 
Step 10 encapsulation frame-relay [cisco | ietf]


Example:
Device(config-if)# encapsulation frame-relay ietf 
 

Specifies Frame Relay encapsulation for the interface.

  • You can specify different types of encapsulations.
  • You can set one interface to Cisco encapsulation and the other interface to IETF encapsulation.
 
Step 11 no keepalive


Example:
Device(config-if)# no keepalive
 

Disables the keepalive configuration.

 
Step 12 service-policy input policy-name


Example:
Device(config-if)# service-policy input policy1 
 

Attaches a traffic policy to the interface.

 
Step 13 end


Example:
Device(config-if)# end
 

Exits connect configuration mode and returns to privileged EXEC mode.

 
Step 14 pseudowire-class [pw-class-name]


Example:
Device(config)# pseudowire-class l2tpv3
 

Specifies the name of a Layer 2 pseudowire class and enters pseudowire class configuration mode.

 
Step 15 encapsulation l2tpv3


Example:
Device(config-pw)# encapsulation l2tpv3 
 

Specifies the tunneling encapsulation as L2TPv3.

 
Step 16 ip local interface loopback loopback id


Example:
Device(config-pw)# ip local interface Loopback0
 

Specifies the local loopback interface.

 
Step 17 connect connection-name interface dlci l2transport


Example:
Device(config-pw)# connect fr1 serial5/0 1000 l2transport
 

Defines connections between Frame Relay Permanent Virtual Circuits (PVCs) and enters connect configuration mode.

  • Using the l2transport keyword specifies that the PVC is not a locally switched PVC, but is tunneled over the backbone network.
  • The connection-name argument is a text string that you provide.
  • The interface argument is the interface on which a PVC connection is defined.
  • The dlci argument is the DLCI number of the PVC that is connected.
 
Step 18 xconnect peer-router-id vcid encapsulation l2tpv3 pw-class l2tpv3


Example:
Device(config-xconnect-conn-config)# xconnect 198.51.100.2 123 encapsulation l2tpv3 pw-class l2tpv3
 

Creates the VC to transport the Layer 2 packets.

  • In a DLCI-to-DLCI connection type, Frame Relay over L2TPv3 uses the xconnect command in connect configuration mode.
 
Step 19 end


Example:
Device(config-xconnect-conn-config)# end
 

Exits connect configuration mode and returns to privileged EXEC mode.

 

Verifying Frame Relay over L2TPv3 Configuration

You can use show commands to view information about a Frame Relay over L2TPv3 configuration.

SUMMARY STEPS

1. show xconnect all detail

2. show frame-relay pvc

3. show connection


DETAILED STEPS
Step 1   show xconnect all detail

The following example is sample output of the show xconnect all detail command:



Example:
Device# show xconnect all detail

Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Se0/2/0:0:16(FR DLCI)        UP l2tp 22.2.2.2:100                 UP
            Interworking: L2L                    Session ID: 306532470
                                                 Tunnel ID: 1381396806
                                                 Protocol State: UP
                                                 Remote Circuit State: UP
                                                 pw-class: fr_fr
UP pri   ac Se0/2/0:0:17(FR DLCI)        UP l2tp 22.2.2.2:101                 UP
            Interworking: Eth                    Session ID: 1373339282
                                                 Tunnel ID: 1381396806
                                                 Protocol State: UP
                                                 Remote Circuit State: UP
                                                 pw-class: fr_eth
Step 2   show frame-relay pvc

The following example is sample output of the show frame-relay pvc command:



Example:
Device# show frame-relay pvc

pseudowire100001 is up, VC status is up PW type: Ethernet
  Create time: 5d20h, last status change time: 5d20h
    Last label FSM state change time: 5d20h
  Destination address: 2.1.1.2 VC ID: 1234000
    Output interface: Et0/0, imposed label stack {2001}
  Preferred path: not configured
  Default path: active
  Next hop: 20.0.0.2
Member of xconnect service Et1/0.1-1001, group right
  Associated member Et1/0.1 is up, status is up
  Interworking type is Ethernet
  Service id: 0x6d000002
Signaling protocol: LDP, peer 2.1.1.2:0 up
  Targeted Hello: 1.1.1.1(LDP Id) -> 2.1.1.2, LDP is UP
  Graceful restart: not configured and not enabled
  Non stop routing: not configured and not enabled
  PWid FEC (128), VC ID: 1234000
  Status TLV support (local/remote) : enabled/supported
    LDP route watch : enabled
    Label/status state machine : established, LruRru
    Local dataplane status received : No fault
    BFD dataplane status received : Not sent
    BFD peer monitor status received : No fault
    Status received from access circuit : No fault
    Status sent to access circuit : No fault
    Status received from pseudowire i/f : No fault
    Status sent to network peer : No fault
    Status received from network peer : No fault
    Adjacency status of remote peer : No fault
Sequencing: receive disabled, send disabled
Bindings
Parameter    Local                          Remote
------------ ------------------------------ ------------------------------
Label        2007                           2001
Group ID     0                              6
Interface
MTU          1500                           1500
Control word on (configured: autosense)     on
PW type      Ethernet                       Ethernet
VCCV CV type 0x12                           0x12
               LSPV [2], BFD/Raw [5]          LSPV [2], BFD/Raw [5]
VCCV CC type 0x07                           0x07
             CW [1], RA [2], TTL [3]        CW [1], RA [2], TTL [3]
Status TLV   enabled                        supported
Dataplane:
  SSM segment/switch IDs: 12309/4115 (used), PWID: 1
Rx Counters
  106563 input transit packets, 9803650 bytes
  0 drops, 0 seq err
Tx Counters
  0 output transit packets, 0 bytes
  0 drops
Step 3   show connection

The following example is sample output of the show connection command:



Example:
Device# show connection

ID   Name            Segment 1              Segment 2                  State
================================================================================
1    fr_fr           Se0/2/0:0 16           22.2.2.2 100               UP
2    fr_eth          Se0/2/0:0 17           22.2.2.2 101               UP

--------------------------

Configuration Examples for Frame Relay over L2TPv3

Example: Frame Relay over L2TPv3 with LMI

The following example shows how to configure Frame Relay over L2TPv3 with Local Management Interface (LMI) enabled:

PE1 device

CE1 device

configure terminal
 interface Serial 0/2/0:0
  no ip address
  encapsulation frame-relay
!
keepalive 15
frame-relay lmi-type cisco
configure terminal
 interface Serial 1/0:0
  no ip address
  encapsulation frame-relay
  frame-relay intf-type dce
!
keepalive 15
frame-relay lmi-type cisco
interface Serial 1/0:0.100 point-to-point
 ip address 198.51.100.33 255.255.255.0
 frame-relay interface-dlci 16

Examples: Frame Relay over L2TPv3 without LMI

The following example shows how to configure Frame Relay DLCI-to-Frame Relay DLCI over L2TPv3 without Local Management Interface (LMI) enabled:

PE1 device

CE1 device

configure terminal
 interface Serial 0/1/0
  encapsulation frame-relay
!
pseudowire-class fr_l2tpv3
 encapsulation l2tpv3
 ip local interface Loopback0
!
connect FR Serial 0/1/0 100 l2transport
 xconnect 198.51.100.2 100 encapsulation l2tpv3 pw-class fr_l2tpv3
configure terminal
 interface Serial 0/0/0
  encapsulation frame-relay
  exit
!
interface Serial 0/0/0.100 point-to-point
 ip address 198.51.100.22 255.255.255.0
 frame-relay interface-dlci 100  

The following example shows how to configure Frame Relay DLCI-to-Ethernet Interworking over L2TPv3 without LMI enabled:

PE1 device

CE1 device

configure terminal
 pseudowire-class fr_eth
 encapsulation l2tpv3
 interworking ethernet
 ip local interface Loopback0
!
connect FR-Eth Serial 0/1/0 500 l2transport
 xconnect 198.51.100.27 500 encapsulation l2tpv3 pw-class fr_eth
configure terminal
 interface Serial 0/0/0.500 point-to-point
 frame-relay interface-dlci 500
!   
interface BVI 200
 ip address 198.51.100.29 255.255.255.0
 

Additional References for Frame Relay over L2TPv3

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Command List, All Releases

MPLS commands

Multiprotocol Label Switching Command Reference

Configuring Frame Relay over MPLS

Configuring Frame Relay over MPLS

MPLS Layer 2 VPNs Configuration Guide

MPLS Layer 2 VPNs Configuration Guide

Standards and RFCs

Standard/RFC Title

RFC 2427

Multiprotocol Interconnect over Frame Relay

RFC 4591

Frame Relay over Layer 2 Tunneling Protocol Version 3 (L2TPv3)

MIBs

MIB MIBs Link
  • Cisco Frame Relay MIB (CISCO-FRAME-RELAY-MIB.my)
  • Interfaces MIB (IF-MIB.my)

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http:/​/​www.cisco.com/​go/​mibs

Technical Assistance

Description Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http:/​/​www.cisco.com/​support

Feature Information for Frame Relay over L2TPv3

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Table 1 Feature Information for Frame Relay over L2TPv3

Feature Name

Releases

Feature Information

Frame Relay over L2TPv3

Cisco IOS XE Release 3.12S

This feature enables Frame Relay switching over Layer 2 Tunnel Protocol Version 3 (L2TPv3). The feature works with like interfaces and disparate interfaces (L2VPN interworking).